Open
Shortest Path First (OPSF) merupakan protokol routing
dinamis yang berkerja berdasarkan algoritma link-state. Kemampuan OSPF dalam
melakukan konvergensi topologi jaringan lebih baik dibanding protokol routing distance-vector
(seperti RIP, IGRP). Hal ini dilakukan untuk membuat skalabilitas dalam suatu
jaringan. Protocol OSPF memiliki konsep area dimana membagi-bagi area jaringan
menjadi beberapa area/lokasi sehingga dapat mempermudah pengaturan suatu
jaringan. Konsep ini menjadi salah satu keunggulan protokol routing OSPF
dibandingkan protokol routing IGP lainnya.
Konsep
AREA protokol OSPF yang akan dibahas pada tutorial konfigurasi ini dengan
menggunakan Packet Tracer. Dipergunakan 5 router sebagai pembangun adjacency
antar neighbor OSPF dan sebuah web_server dan sebuah host yang digunakan untuk
uji koneksi jaringan. Uji koneksi Jaringan Multi Area OSPF dilakukan dengan
aplikasi http pada web_server yang diakses melalui host.
Area
0 (area zero) terdapat hubungan antara router #R2, #R3, dan #R4.
Router-router ini berada pada backbone area OSPF sebagai penghubung antara Area
1 dan Area2. Sementara untuk Area 1 adjacency antar #R1 dan #R2, sedangkan Area
2 adjacency antar #R5 dan #R4. Masing-masing router pada tiap-tiap area
memiliki informasi routing yang berbeda-beda.
Berikut konfigurasi masing-masing
router, seperti dibawah ini:
#R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.10.50.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 50.100.200.1 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 1.1.1.1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 1
network 50.100.200.0 0.0.0.3 area 1
network 1.1.1.1 0.0.0.0 area 1
network 10.10.50.0 0.0.0.255 area 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 50.100.200.2
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.10.50.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 50.100.200.1 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 1.1.1.1
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 1
network 50.100.200.0 0.0.0.3 area 1
network 1.1.1.1 0.0.0.0 area 1
network 10.10.50.0 0.0.0.255 area 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 50.100.200.2
!
#R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.2 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.5 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 2.2.2.2
log-adjacency-changes
network 50.100.200.4 0.0.0.3 area 0
network 2.2.2.2 0.0.0.0 area 0
network 50.100.200.0 0.0.0.3 area 1
!
ip address 2.2.2.2 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.2 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.5 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 2.2.2.2
log-adjacency-changes
network 50.100.200.4 0.0.0.3 area 0
network 2.2.2.2 0.0.0.0 area 0
network 50.100.200.0 0.0.0.3 area 1
!
#R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.6 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.9 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 3.3.3.3
log-adjacency-changes
network 50.100.200.8 0.0.0.3 area 0
network 50.100.200.4 0.0.0.3 area 0
network 3.3.3.3 0.0.0.0 area 0
!
ip address 3.3.3.3 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.6 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.9 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 3.3.3.3
log-adjacency-changes
network 50.100.200.8 0.0.0.3 area 0
network 50.100.200.4 0.0.0.3 area 0
network 3.3.3.3 0.0.0.0 area 0
!
#R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.10 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.13 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 4.4.4.4
log-adjacency-changes
network 50.100.200.8 0.0.0.3 area 0
network 4.4.4.4 0.0.0.0 area 0
network 50.100.200.12 0.0.0.3 area 2
!
ip address 4.4.4.4 255.255.255.255
!
interface Serial2/0
ip address 50.100.200.10 255.255.255.252
no keepalive
!
interface Serial3/0
ip address 50.100.200.13 255.255.255.252
no keepalive
clock rate 56000
!
router ospf 212
router-id 4.4.4.4
log-adjacency-changes
network 50.100.200.8 0.0.0.3 area 0
network 4.4.4.4 0.0.0.0 area 0
network 50.100.200.12 0.0.0.3 area 2
!
#R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 50.50.50.1 255.255.255.0
!
interface FastEthernet0/0
ip address 50.50.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 50.100.200.14 255.255.255.252
no keepalive
!
router ospf 212
router-id 5.5.5.5
log-adjacency-changes
network 50.100.200.12 0.0.0.3 area 2
network 50.50.50.0 0.0.0.255 area 2
network 5.5.5.5 0.0.0.0 area 2
network 50.50.10.0 0.0.0.255 area 2
!
ip classless
ip route 0.0.0.0 0.0.0.0 50.100.200.13
!
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 50.50.50.1 255.255.255.0
!
interface FastEthernet0/0
ip address 50.50.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 50.100.200.14 255.255.255.252
no keepalive
!
router ospf 212
router-id 5.5.5.5
log-adjacency-changes
network 50.100.200.12 0.0.0.3 area 2
network 50.50.50.0 0.0.0.255 area 2
network 5.5.5.5 0.0.0.0 area 2
network 50.50.10.0 0.0.0.255 area 2
!
ip classless
ip route 0.0.0.0 0.0.0.0 50.100.200.13
!
Nah…..tabel
routing dibawah ini memberikan keterangan informasi area-area ospf yang
berhasil disimpan dalam tabel routing router OSPF. Missal untuk router yang
berada pada Area 0, memiliki infomasi Area 0 sesuai dengan dimana router
tersebut berada. Untuk lebih jelas silahkan perhatikan infoamsi tabel routing
dibawah ini.
Tabel
Routing #R1
Tabel
Routing #R3
Tabel
Routing #R5
Informasi
routing yang berhasil dikumpulan oleh router Area 1 dan router Area 2. Tabel
routing router #R1 dan #R5 terlihat informasi path internal area dengan tanda
IA OSPF. Path ini mengindikasikan path dalam internal protocol OSPF itu
sendiri. Seperti gambar tabel-tabel RIB OSPF dibawah ini.
Tabel
Routing RIB #R1
Tabel
Routing RIB #R5
Terakhir
melakukan uji test koneksi dengan mengirimkan pesan PING atau mengkases
aplikasi HTTP web_server melalui host.
Ternyata
web_server berhasil diakses melalui host, artinya konfigurasi sukses. Agar
lebih paham silahkan dipraktekkan pada packet tracer atau simulator lainnya.
Semoga
berhasil yuaaaaaaaaaaa!!!!!!!!!!!!!!!
0 komentar:
Posting Komentar